Support forum of the software localization tool Sisulizer


.NET, Delphi, ... - Sisulizer Localization Tool Support Home

Get in contact with the makers of Sisulizer.
Our forum is open for all questions around Sisulizer from customers and prospects.
Don't hesitate to register and ask. The Sisulizer team will answer ASAP.

Search     Help Home Sisulizer Website Download
Search by username
Not logged in - Login | Register 

 Moderated by: Sisusupport, Renate.Reinartz, Markus.Kreisel, Ilkka.Salmenius Page:    1  2  Next Page Last Page  
New Topic Reply Printer Friendly
No excape sequences in Java properties file - Bugs and Quirks in Sisulizer - Technical Support (You need to be registered at the forum to write) - .NET, Delphi, ... - Sisulizer Localization Tool Support
AuthorPost
 Posted: Wed Mar 8th, 2017 03:42 pm
PM Private Upload Quote Reply
heikovoss2
Member
 

Joined: Fri Nov 20th, 2015
Location:  
Posts: 8
Status: 
Offline
Hello,
I have java properties file which I want to translate with Sisulizer. With build 363 signs which are not part of the ISO-coding are encoded as escape sequences in the translated files. Since build 364 they are encoded in a different way.

I need the old way with escape sequences. I tried to work with new encoding but that created a lot of issues.
And why was that changed and I found nothing in your documentation?

Kind regards
Heiko Voss

P.S. I've tried to upload some examples files but got always error message, when I tried to upload it via Private Upload button.
H.V.

Last edited on Wed Mar 8th, 2017 03:54 pm by heikovoss2

Back To Top PM Private Upload Quote Reply

 Posted: Wed Mar 8th, 2017 03:59 pm
PM Private Upload Quote Reply
Markus.Kreisel
Administrator


Joined: Sat Apr 8th, 2006
Location: Monschau, Germany
Posts: 3024
Status: 
Offline
I've to ask R&D what can happen to it. I'm not aware of changes to it. Can you please use Private Upload to send a file (zipped) with the Escape sequence. Please add some comment about the sequence so we can take a look.

In the meantime you might find an older build here:
https://www.sisulizer.com/support/downloads/versionarchive.shtml

Markus



____________________
http://www.sisulizer.com - Three simple steps to localize
Back To Top PM Private Upload Quote Reply

 Posted: Wed Mar 8th, 2017 04:28 pm
PM Private Upload Quote Reply
heikovoss2
Member
 

Joined: Fri Nov 20th, 2015
Location:  
Posts: 8
Status: 
Offline
I'm nopt able to upload something with Private Upload. I've tried more 6 times now. I receive always error message:
"The link to our support forum seems to be incorrect. You need to use the Private Upload button above your post in our support forum. This will automatically fill the field with the information our support team needs to process your request."
Sorry!

In the meanwhile I'm working with build 363.

Back To Top PM Private Upload Quote Reply

 Posted: Wed Mar 8th, 2017 04:29 pm
PM Private Upload Quote Reply
heikovoss2
Member
 

Joined: Fri Nov 20th, 2015
Location:  
Posts: 8
Status: 
Offline
But I used that button above my post...

Back To Top PM Private Upload Quote Reply

 Posted: Wed Mar 8th, 2017 04:30 pm
PM Private Upload Quote Reply
heikovoss2
Member
 

Joined: Fri Nov 20th, 2015
Location:  
Posts: 8
Status: 
Offline
Do you have email? I will send you tomorrow example project.

Back To Top PM Private Upload Quote Reply

 Posted: Wed Mar 8th, 2017 05:06 pm
PM Private Upload Quote Reply
Janusz Grzybek
Super Moderator


Joined: Fri Dec 1st, 2006
Location: Zabrze, Poland
Posts: 3770
Status: 
Offline
heikovoss2 wrote: I'm nopt able to upload something with Private Upload. I've tried more 6 times now. I receive always error message:
"The link to our support forum seems to be incorrect. You need to use the Private Upload button above your post in our support forum. This will automatically fill the field with the information our support team needs to process your request."
Sorry!

You are right. It doesn't work correctly for now. We recently moved our support pages to more secure https, and it can be reason of upload error. I'll ask our webmaster about this.

Janusz



____________________
http://www.sisulizer.com - Three simple steps to localize
Back To Top PM Private Upload Quote Reply

 Posted: Wed Mar 8th, 2017 06:11 pm
PM Private Upload Quote Reply
Markus.Kreisel
Administrator


Joined: Sat Apr 8th, 2006
Location: Monschau, Germany
Posts: 3024
Status: 
Offline
The Private Upload has been fixed.

Indeed it was related to our https switch. Nasty little bug in a routine keeping spamers away from our upload form...

Sorry for the hassle.

Markus



____________________
http://www.sisulizer.com - Three simple steps to localize
Back To Top PM Private Upload Quote Reply

 Posted: Thu Mar 9th, 2017 08:46 am
PM Private Upload Quote Reply
heikovoss2
Member
 

Joined: Fri Nov 20th, 2015
Location:  
Posts: 8
Status: 
Offline
Hello,
I've tried private upload again, and it worked now. But I didn't comment:

Old properties file (as it should be, created with build 363) is in:
java\src\com\umiversal\meditools\Messages_pl - correct output build 363.properties

New (created with build 364 and 366)
Messages_pl.properties

Greetings
Heiko

Back To Top PM Private Upload Quote Reply

 Posted: Thu Mar 9th, 2017 02:27 pm
PM Private Upload Quote Reply
Janusz Grzybek
Super Moderator


Joined: Fri Dec 1st, 2006
Location: Zabrze, Poland
Posts: 3770
Status: 
Offline
Thank you for reporting this. Sisulizer should use Unicode Escape instead Windows 1250 in this case. In theory, you can manually set correct encoding via "Project" menu -> "Edit Source" -> your source properties file -> "Encodings" tab, but it doesn't work in the current build. After changing output encoding to Unicode Escape, Sisulizer automatically back encoding to Windows 1250. I'll forward this to our developer.

Janusz



____________________
http://www.sisulizer.com - Three simple steps to localize
Back To Top PM Private Upload Quote Reply

 Posted: Fri Mar 10th, 2017 10:24 am
PM Private Upload Quote Reply
heikovoss2
Member
 

Joined: Fri Nov 20th, 2015
Location:  
Posts: 8
Status: 
Offline
Yes I tried to change the settings of encoding of the file but result was not satisfying.
Then I integrated a work around in my source code which worked with polish language on my german windows. But work around didn't work for polish customers with polish windows...

It was some trouble. But generally I like your tool and your support, too. :-)

I will wait for next build with bugfix. Until then I will work with build 363.

Heiko

Back To Top PM Private Upload Quote Reply

 Posted: Fri Mar 10th, 2017 05:29 pm
PM Private Upload Quote Reply
Ilkka.Salmenius
Administrator


Joined: Wed Aug 8th, 2007
Location: Tokyo, Japan
Posts: 1979
Status: 
Offline
I fixed this bug. Starting from build 367 the default output encoding is again Unicode escape but you can change to any other supported encoding.

Ilkka



____________________
http://www.sisulizer.com - Three simple steps to localize
Back To Top PM Private Upload Quote Reply

 Posted: Tue Mar 21st, 2017 03:00 pm
PM Private Upload Quote Reply
heikovoss2
Member
 

Joined: Fri Nov 20th, 2015
Location:  
Posts: 8
Status: 
Offline
Hello Ilkka,
thanks for fixing.

In build 366 not only the default encoding changed.

It is also not possible to change the option to "Unicode-Escape". I tried it, but Sisulizer doesn't save the change. After changing and closing the window with OK, and then reopening, the encoding is again something like "western europe windows ..." or "eastern europe windows ...".

Heiko

Back To Top PM Private Upload Quote Reply

 Posted: Tue Mar 21st, 2017 03:01 pm
PM Private Upload Quote Reply
heikovoss2
Member
 

Joined: Fri Nov 20th, 2015
Location:  
Posts: 8
Status: 
Offline
Forget my last replay. :-)
Heiko

Back To Top PM Private Upload Quote Reply

 Posted: Tue Mar 21st, 2017 03:30 pm
PM Private Upload Quote Reply
Markus.Kreisel
Administrator


Joined: Sat Apr 8th, 2006
Location: Monschau, Germany
Posts: 3024
Status: 
Offline
You are welcome :-)

Thanks for your feedback

Markus



____________________
http://www.sisulizer.com - Three simple steps to localize
Back To Top PM Private Upload Quote Reply

 Posted: Fri Mar 31st, 2017 01:26 am
PM Private Upload Quote Reply
ebrk001
Member
 

Joined: Tue Apr 5th, 2016
Location:  
Posts: 5
Status: 
Offline
Hi Marcus,

My apologies if this has been covered elsewhere, but where do I actually find the "Escape character" setting as described in the Help and also on your website. We are using Sisulizer 3, build 336. I looked through all menus and would have expected the setting to be in Project > Options.

Cheers,

Kurt

Back To Top PM Private Upload Quote Reply

 Posted: Fri Mar 31st, 2017 06:09 am
PM Private Upload Quote Reply
Markus.Kreisel
Administrator


Joined: Sat Apr 8th, 2006
Location: Monschau, Germany
Posts: 3024
Status: 
Offline
Look for Project - Edit Source -<your source>. A project can have more than one source and needs settings for each of them besides the global settings you mentioned.

Markus



____________________
http://www.sisulizer.com - Three simple steps to localize
Back To Top PM Private Upload Quote Reply

 Posted: Sun Apr 2nd, 2017 10:45 pm
PM Private Upload Quote Reply
ebrk001
Member
 

Joined: Tue Apr 5th, 2016
Location:  
Posts: 5
Status: 
Offline
Hi Markus,

Thanks for the tip. I get a dialog with the title "Java Resource Source  - [source]"  and the following tabs:
File / Options / Encodings / Additional files / Excluded files / Spelling / Engines.

However, I still don't seem to be able to find the "Escape character" settings.

Cheers,

Kurt

Back To Top PM Private Upload Quote Reply

 Posted: Mon Apr 3rd, 2017 09:04 am
PM Private Upload Quote Reply
Markus.Kreisel
Administrator


Joined: Sat Apr 8th, 2006
Location: Monschau, Germany
Posts: 3024
Status: 
Offline
The escape sequences in the output this thread refeers about are changed under the encodings tab.

It is not about escapes in the source like described here: https://www.sisulizer.com/online-help/EscapeCharacter.shtml

This setting exist in the same dialog but only for selected platforms (e.g. text files...). If the escapes are defined in the platform standard you can not change them.

Markus



____________________
http://www.sisulizer.com - Three simple steps to localize
Back To Top PM Private Upload Quote Reply

 Posted: Mon Apr 3rd, 2017 09:04 am
PM Private Upload Quote Reply
Markus.Kreisel
Administrator


Joined: Sat Apr 8th, 2006
Location: Monschau, Germany
Posts: 3024
Status: 
Offline
The escape sequences in the output this thread refeers about are changed under the encodings tab.

It is not about escapes in the source like described here: https://www.sisulizer.com/online-help/EscapeCharacter.shtml

This setting exist in the same dialog but only for selected platforms (e.g. text files...). If the escapes are defined in the platform standard you can not change them.

Markus



____________________
http://www.sisulizer.com - Three simple steps to localize
Back To Top PM Private Upload Quote Reply

 Posted: Mon Apr 3rd, 2017 10:19 am
PM Private Upload Quote Reply
Markus.Kreisel
Administrator


Joined: Sat Apr 8th, 2006
Location: Monschau, Germany
Posts: 3024
Status: 
Offline
As mentioned the setting for the source exist only for a few selected platforms. The escape sequences for Java are fixed and can`t be changed.

The output sequences are controlled by the codepage setting (e.g. Windows 1250) in encodings. This is what the thread originaly was about. Depending on the codepage the output is escaped differently.

Markus



____________________
http://www.sisulizer.com - Three simple steps to localize
Back To Top PM Private Upload Quote Reply

Current time is 04:30 am Page:    1  2  Next Page Last Page    
.NET, Delphi, ... - Sisulizer Localization Tool Support > Technical Support (You need to be registered at the forum to write) > Bugs and Quirks in Sisulizer > No excape sequences in Java properties file



WowUltra modified by Sisulizer Copyright © 2007-09 by Jim Hale - Based on WowBB Copyright © 2003-2006 Aycan Gulez

Sisulizer software localization tool - Three simple steps to localize