Support forum of the software localization tool Sisulizer


.NET, Delphi, ... - Sisulizer Localization Tool Support Home

Get in contact with the makers of Sisulizer.
Our forum is open for all questions around Sisulizer from customers and prospects.
Don't hesitate to register and ask. The Sisulizer team will answer ASAP.

Search     Help Home Sisulizer Website Download
Search by username
Not logged in - Login | Register 

 Moderated by: Sisusupport, Renate.Reinartz, Markus.Kreisel, Ilkka.Salmenius
New Topic Reply Printer Friendly
V4.0 370 Issues - Bugs and Quirks in Sisulizer - Technical Support (You need to be registered at the forum to write) - .NET, Delphi, ... - Sisulizer Localization Tool Support
AuthorPost
 Posted: Mon Mar 12th, 2018 01:45 pm
PM Private Upload Quote Reply
Massoud
Member
 

Joined: Sun Apr 11th, 2010
Location: Mountain View, California USA
Posts: 31
Status: 
Offline
I updated to Build 370 last week and since then, Sisu does not show the items to translate correctly.

In the attached screen capture you can see that there are no filters, but the selected node from the tree does not display neither Completed nor Not translated items. Also the statistics window shows zero count for everything. But in the XML there are both Completed and Not translated items (can see one of each in screen capture).
This was working fine in Build 369.

Attachment: Sisu370.png (Downloaded 20 times)

Back To Top PM Private Upload Quote Reply

 Posted: Mon Mar 12th, 2018 02:16 pm
PM Private Upload Quote Reply
Markus.Kreisel
Administrator


Joined: Sat Apr 8th, 2006
Location: Monschau, Germany
Posts: 3152
Status: 
Offline
Hi,

Please upload you .slp. There is a Private Upliad button right above this post for that.

If you are in a hurry you can download older builds from our archive on the website - while I don`t think there is a serious issue in Sisulizer and we might sort that out fast.

Markus



____________________
http://www.sisulizer.com - Three simple steps to localize
Back To Top PM Private Upload Quote Reply

 Posted: Mon Mar 12th, 2018 02:38 pm
PM Private Upload Quote Reply
Massoud
Member
 

Joined: Sun Apr 11th, 2010
Location: Mountain View, California USA
Posts: 31
Status: 
Offline
Thank you for the quick response, I think I now know what is happening. I generated an Export .sle for French (France) and I selected "Only first Instance" under Other/Duplicates. That is why it is not showing these nodes as Complete. If I select "No filter" it works fine. I do not know if this is a bug or a expected behavior.
I will continue for now and if I see anything else, I will report it.
Again, thank you Markus for quick reply.

Back To Top PM Private Upload Quote Reply

 Posted: Tue Mar 13th, 2018 03:32 pm
PM Private Upload Quote Reply
Massoud
Member
 

Joined: Sun Apr 11th, 2010
Location: Mountain View, California USA
Posts: 31
Status: 
Offline
What we have found is that some Export .sle files take more than 15 minutes to open in some machines and are extremely slow once they open (and they work perfectly in other machines).

Any ideas why?

Back To Top PM Private Upload Quote Reply

 Posted: Tue Mar 13th, 2018 03:44 pm
PM Private Upload Quote Reply
Massoud
Member
 

Joined: Sun Apr 11th, 2010
Location: Mountain View, California USA
Posts: 31
Status: 
Offline
After further testing, it seems the freezing issue only happens in Windows 10 1709 (16299.248)

Back To Top PM Private Upload Quote Reply

 Posted: Tue Mar 13th, 2018 03:52 pm
PM Private Upload Quote Reply
Markus.Kreisel
Administrator


Joined: Sat Apr 8th, 2006
Location: Monschau, Germany
Posts: 3152
Status: 
Offline
Hi,

Please upload you .sle. There is a Private Upliad button right above this post for that.
We try to load it here with latest W10.
Markus



____________________
http://www.sisulizer.com - Three simple steps to localize
Back To Top PM Private Upload Quote Reply

 Posted: Tue Mar 13th, 2018 05:15 pm
PM Private Upload Quote Reply
Massoud
Member
 

Joined: Sun Apr 11th, 2010
Location: Mountain View, California USA
Posts: 31
Status: 
Offline
Just uploaded the .sle file

Back To Top PM Private Upload Quote Reply

 Posted: Tue Mar 13th, 2018 05:35 pm
PM Private Upload Quote Reply
Markus.Kreisel
Administrator


Joined: Sat Apr 8th, 2006
Location: Monschau, Germany
Posts: 3152
Status: 
Offline
Just tested with W10 1709 and Sisulizer 368/370. It loads in just a few seconds.
I just dropped the .sle to the desktop and double-clicked. I have admin rights.

You must have changed something on your 1709 machines. Try to start Sisulizer as admin (Run as admin) while logged in as admin for a test to find out rights issues. Store the .sle locally to exclude network issues. Check the event log of Windows for errors.

Markus

Markus



____________________
http://www.sisulizer.com - Three simple steps to localize
Back To Top PM Private Upload Quote Reply

 Posted: Tue Mar 13th, 2018 05:35 pm
PM Private Upload Quote Reply
Massoud
Member
 

Joined: Sun Apr 11th, 2010
Location: Mountain View, California USA
Posts: 31
Status: 
Offline
Just tested after latest Windows Update 16299.251 and it is still slow.

Open .sle takes 10+ minutes. Mouse clicks to change selection takes 10-15 seconds, and key clicks take 3-5 seconds.

Back To Top PM Private Upload Quote Reply

 Posted: Tue Mar 13th, 2018 05:42 pm
PM Private Upload Quote Reply
Massoud
Member
 

Joined: Sun Apr 11th, 2010
Location: Mountain View, California USA
Posts: 31
Status: 
Offline
Run As Administrator did not help.
.slp file is in Local disk.
No errors in Event Logs.

We tested on 3 different Laptops, all with same issue.

Back To Top PM Private Upload Quote Reply

 Posted: Tue Mar 13th, 2018 05:52 pm
PM Private Upload Quote Reply
Massoud
Member
 

Joined: Sun Apr 11th, 2010
Location: Mountain View, California USA
Posts: 31
Status: 
Offline
I used SysInternals Process Monitor to see what Sisulizer.exe is doing. To my surprise, with every click, it is reading/accessing ALL the files in my C: drive!!!
I have uploaded the capture .PML file. You can open it with the PM tool.

Back To Top PM Private Upload Quote Reply

 Posted: Tue Mar 13th, 2018 06:20 pm
PM Private Upload Quote Reply
Massoud
Member
 

Joined: Sun Apr 11th, 2010
Location: Mountain View, California USA
Posts: 31
Status: 
Offline
Hi Markus,

I found what is happening!
You notice that the paths in my .sle are relative like ..\..\*.resx etc.

If the .sle is stored in, say, C:\Temp\sisu\my.sle then every click in the app is making it read from two directories up recursively (which is C:\ in the example). And that is why it is slow.

If I store the .sle in say C:\Temp\sisu\a\b\my.sle, then it opens quickly and is responsive, because in two directories up, there are not many files.

I would say this is a Product Defect.

Regards
Massoud

Back To Top PM Private Upload Quote Reply

 Posted: Tue Mar 13th, 2018 06:59 pm
PM Private Upload Quote Reply
Markus.Kreisel
Administrator


Joined: Sat Apr 8th, 2006
Location: Monschau, Germany
Posts: 3152
Status: 
Offline
In the root Sisulizer will not have the needed rights to write.
The relative paths are needed to allow an easy relocation of projects. Else absolute paths will be needed making exchange very hard.

I'll ask R&D if it is possible to check for user rights in case of relative paths. Perhaps some warning can be shown or a dialog to choose a different path.

Markus
 



____________________
http://www.sisulizer.com - Three simple steps to localize
Back To Top PM Private Upload Quote Reply

 Posted: Fri Mar 16th, 2018 01:45 am
PM Private Upload Quote Reply
Ilkka.Salmenius
Administrator


Joined: Wed Aug 8th, 2007
Location: Tokyo, Japan
Posts: 2009
Status: 
Offline
Hi Massoud,

There was a bug. It caused your project opening to contain very long time. I fixed it. The fix will be the next build (371) that will be released in few weeks.

Ilkka



____________________
http://www.sisulizer.com - Three simple steps to localize
Back To Top PM Private Upload Quote Reply

 Posted: Fri Mar 16th, 2018 04:48 pm
PM Private Upload Quote Reply
Massoud
Member
 

Joined: Sun Apr 11th, 2010
Location: Mountain View, California USA
Posts: 31
Status: 
Offline
Thanks Ilkka. Looking forward to it.

Back To Top PM Private Upload Quote Reply

Current time is 06:28 pm  
.NET, Delphi, ... - Sisulizer Localization Tool Support > Technical Support (You need to be registered at the forum to write) > Bugs and Quirks in Sisulizer > V4.0 370 Issues



WowUltra modified by Sisulizer Copyright © 2007-18 by Jim Hale - Based on WowBB Copyright © 2003-2006 Aycan Gulez

Impress - Privacy statement

Sisulizer software localization tool - Three simple steps to localize