Support forum of the software localization tool Sisulizer


.NET, Delphi, ... - Sisulizer Localization Tool Support Home

Get in contact with the makers of Sisulizer.
Our forum is open for all questions around Sisulizer from customers and prospects.
Don't hesitate to register and ask. The Sisulizer team will answer ASAP.

Search     Help Home Sisulizer Website Download
Search by username
Not logged in - Login | Register 

 Moderated by: Sisusupport, Renate.Reinartz, Markus.Kreisel, Ilkka.Salmenius
New Topic Reply Printer Friendly
Need some additional line breaks in Translation - Usage - Three simple steps to localize - Technical Support (You need to be registered at the forum to write) - .NET, Delphi, ... - Sisulizer Localization Tool Support
AuthorPost
 Posted: Tue Jun 26th, 2018 02:05 pm
PM Private Upload Quote Reply
Mellon
Member
 

Joined: Mon Jan 22nd, 2018
Location:  
Posts: 5
Status: 
Offline
Hi Forum,
I am working on a C#, WPF Project using Sisulizer 4.0 372
We get some translations, that are somewhat longer than the origin. I like to use an additional line break in the translation, but if there is no line break in the original, the translation line break is omitted in the translated assembly.
Is there a property that i have missed? White spaces normalisation is not checked!
Greetings,Dennis

Back To Top PM Private Upload Quote Reply

 Posted: Tue Jun 26th, 2018 02:31 pm
PM Private Upload Quote Reply
Markus.Kreisel
Administrator


Joined: Sat Apr 8th, 2006
Location: Monschau, Germany
Posts: 3128
Status: 
Offline
Hi Dennis,
have you tried to use Ctrl-Enter, so you see the line break char?
Markus



____________________
http://www.sisulizer.com - Three simple steps to localize
Back To Top PM Private Upload Quote Reply

 Posted: Wed Jun 27th, 2018 09:13 am
PM Private Upload Quote Reply
Mellon
Member
 

Joined: Mon Jan 22nd, 2018
Location:  
Posts: 5
Status: 
Offline
Hi Markus,

yes, the line break char is visible.

I took some Screenshots for Explanation.

The origin is en-gb.

Origin column without and translation column with line break produces an assembly and GUI without linebreak.


When an additional line break is added to the origin,
this leads to GUI Output with linebreak. But i do not want to add this line break into the origin.

Also, the origin is available (5 Times) in different context of the source, always without the line break to be necessary!

The target is located in the text Attribute of a TextBox inside a XAML file.

Thx for any suggestions,
Dennis

Attachment: Sisulizer_LineBreak_Issue.png (Downloaded 9 times)

Back To Top PM Private Upload Quote Reply

 Posted: Wed Jun 27th, 2018 09:26 am
PM Private Upload Quote Reply
Markus.Kreisel
Administrator


Joined: Sat Apr 8th, 2006
Location: Monschau, Germany
Posts: 3128
Status: 
Offline
Can you please upload your SLP plus one XAML with and one without the line break (= the sources you used for both screen shots).

Markus



____________________
http://www.sisulizer.com - Three simple steps to localize
Back To Top PM Private Upload Quote Reply

 Posted: Wed Jun 27th, 2018 09:54 am
PM Private Upload Quote Reply
Markus.Kreisel
Administrator


Joined: Sat Apr 8th, 2006
Location: Monschau, Germany
Posts: 3128
Status: 
Offline
One thing to check upfront. If the original has a line break in XAML it must be surrounded by a CDATA tag. If the other does not have the CDATA tag will be omitted. So if Sisulizer creates the output it can`t place a line break in an entity without CDATA since it is against the rules.

Can you please check if this is what does happen please?

Markus



____________________
http://www.sisulizer.com - Three simple steps to localize
Back To Top PM Private Upload Quote Reply

 Posted: Wed Jun 27th, 2018 03:00 pm
PM Private Upload Quote Reply
Mellon
Member
 

Joined: Mon Jan 22nd, 2018
Location:  
Posts: 5
Status: 
Offline
Hello Markus,

i am working on the upload data.

Till now a checked a bit with VisualStudio, and discovered that our xaml is handmade... therefore we get a text with linebreaks like seen below, with the CR-LF coded directly. When using the Visual Editor, the xaml file Looks quite different :-)

<TextBlock Grid.Column="0" Text="DISPERSER&#10;&#13;" Style="{StaticResource SettingsLabelStyle}" VerticalAlignment="Center" Margin="0 0 8 0"/>

Thx,
Dennis

Last edited on Wed Jun 27th, 2018 03:04 pm by Mellon

Back To Top PM Private Upload Quote Reply

 Posted: Thu Jun 28th, 2018 10:19 am
PM Private Upload Quote Reply
Markus.Kreisel
Administrator


Joined: Sat Apr 8th, 2006
Location: Monschau, Germany
Posts: 3128
Status: 
Offline
Hi Dennis,

try to add instead of CTRL-ENTER to force a line break in the output. Perhaps that does the trick for now.

Markus



____________________
http://www.sisulizer.com - Three simple steps to localize
Back To Top PM Private Upload Quote Reply

 Posted: Thu Jun 28th, 2018 01:30 pm
PM Private Upload Quote Reply
Mellon
Member
 

Joined: Mon Jan 22nd, 2018
Location:  
Posts: 5
Status: 
Offline
Hello Markus,

i put a \n or \r\n and even the XML representation into the translation, but this is escaped and displayed as is in the translated assembly.

I am still trying, maybe i need to use a binding to insert the text.

Greetings,
Dennis

Back To Top PM Private Upload Quote Reply

Current time is 10:47 am  
.NET, Delphi, ... - Sisulizer Localization Tool Support > Technical Support (You need to be registered at the forum to write) > Usage - Three simple steps to localize > Need some additional line breaks in Translation



WowUltra modified by Sisulizer Copyright © 2007-18 by Jim Hale - Based on WowBB Copyright © 2003-2006 Aycan Gulez

Impress - Privacy statement

Sisulizer software localization tool - Three simple steps to localize